Ducati 959 Panigale Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 · (Edited)
Hey guys!

Wondering if you can help me out. I've been on tour for a few months so I haven't had the chance to ride but before that Yuki was my daily driver. Just looking to figure out what exactly the issues might be for starting my bike again. I've hooked up the battery to a charger, and as you can see in the video it says 95% and has even said 100% when I've tried to charge it multiple times, no matter what I try it won't start. Usually it's just a series of clicks and wurrs like a normal setup but as you'll see in the video something about the fuel lines sounds weird not sure what the problem could be.

I'll attach a video from youtube for particulars on what goes on when I do try to start her.

Anything would help, cheers!

https://youtu.be/oc4U8FlJH9w
 

·
Registered
Joined
·
1,937 Posts
I’m guessing there’s a poor connection on a harness somewhere or the tender lead has mucked something up - check all the wiring around the battery and remove the tender - does the bike exhibit the same behavior?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
123 Posts
had the same issue, it was just a loose battery terminal connection. Left me stranded twice. lol
 

·
Registered
Joined
·
892 Posts
Hopefully its a loose battery terminal and it's not shorting anywhere.
 

·
Registered
Joined
·
190 Posts
Where is the battery on this thing, and do they normally come with a tender lead installed?
 

·
Registered
Joined
·
439 Posts
Where is the battery on this thing, and do they normally come with a tender lead installed?
left side fairing.

Ducati factory charger is under the seat, however most dealers install a tender cable coming out near the left engine cover.
 
1 - 6 of 6 Posts
Top