Ducati 959 Panigale Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
Riding home tonight, in N at a trafic light a notice the bike ideling rough, like someone is blipping the throttle. Look down and the dash is going nuts every light (indicators / high beam / check engine / oil / mode settings - the lot) all flashing. The lights on te bike are floskerijg from low to high and both indicators flashing. It stopped after a few minutes. Got home check engine light still on. God give me strength.
 

·
Premium Member
Joined
·
462 Posts
Riding home tonight, in N at a trafic light a notice the bike ideling rough, like someone is blipping the throttle. Look down and the dash is going nuts every light (indicators / high beam / check engine / oil / mode settings - the lot) all flashing. The lights on te bike are floskerijg from low to high and both indicators flashing. It stopped after a few minutes. Got home check engine light still on. God give me strength.
That sucks! Sorry to hear about this happening. I'm assuming that you're taking it in to the dealer? Did you happen to take a picture or a video of the dash?

Sent from my LGLS996 using Tapatalk
 

·
Registered
Joined
·
892 Posts
That sounds insane. I hope its something simple like a loose battery connection and not something worse like alternator, ECU problems, or some obscure wiring gremlin. In any case, sounds like a warranty issue.
 

·
Registered
Joined
·
37 Posts
Really sounds like a loose connection, could explain rough idle and definitely would explain flashing lights and craziness. Keep us updated!
 

·
Registered
Joined
·
892 Posts

·
Registered
Joined
·
1,919 Posts
Yeah, looks like a Debug mode... Interesting to say the least!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
892 Posts
Oh right, I guess another possibility is shorting of wires. Did it rain or was your 959 drenched in any way recently? Most electrical components should be protected from water and/or water resistant, so this is a stretch.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #9
Just been towed to the dealer, as both indicators would not stop blocking and headlights flashing on high beam. Wasn't worth riding and getting hit by someone. Will post up what they find.
 

·
Registered
Joined
·
1,919 Posts
@MileyCyrus - did you happen to check the ECU connection below the lip of the gas tank? maybe it's just coming out from a broken connector... or the ground to the tank in the same location came off?

eagerly awaiting your update!
 

·
Registered
Joined
·
56 Posts
Discussion Starter #11
Dealer called, they said they fixed the initial error and now the bike is throwing up more error codes! They'll need it for a few days. YAY
 

·
Registered
Joined
·
56 Posts
Discussion Starter #16
Picked up from the dealer on Wednesday - they said it was an ECU issue. Reset the ECU and the issue was gone. Started the bike at the dealer and would you look at that the [email protected]&king check engine light is still on.

They called back a few days later and now apparently the issue is the gear position sensor. Of course this part is on back order so they have no idea how far away it is.

This is BS
 

·
Registered
Joined
·
63 Posts
Did they bother to check any connections or just rely on scanning? Techs are getting worse, no diagnostic skills.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #18
Update - got a call today, gear position sensor replaced issue is NOT resolved. They in contact with Ducati now to further out what's next. They think it's the ECU, at this stage I'm getting ready to demand it be replaced. They've had the bike for over a month and are no closer to fixing the issue at all.
 

·
Registered
Joined
·
1 Posts
Update - got a call today, gear position sensor replaced issue is NOT resolved. They in contact with Ducati now to further out what's next. They think it's the ECU, at this stage I'm getting ready to demand it be replaced. They've had the bike for over a month and are no closer to fixing the issue at all.
Any updates mate?

For the past few weeks ive had check engine lights and this same problem occur but it has usually gone away, apart from the check engine light. This last time the dash lit up like yours my odometer reading has disappeared, it is now just some flashing dashes - - - - - -

Bike is now at the dealer again, I have no faith in them or the bike really.

It also has the cold start issue but I have found its a lot better when I exclusively run shell 95.

What area are you in Miley?
 

·
Registered
Joined
·
56 Posts
Discussion Starter #20
Any updates mate?

For the past few weeks ive had check engine lights and this same problem occur but it has usually gone away, apart from the check engine light. This last time the dash lit up like yours my odometer reading has disappeared, it is now just some flashing dashes - - - - - -

Bike is now at the dealer again, I have no faith in them or the bike really.

It also has the cold start issue but I have found its a lot better when I exclusively run shell 95.

What area are you in Miley?

I'm in Aus

Bike was refunded and I purchased a zx10r. Too many problems and the dealership nor Ducati could figure it what the problem was. Best of luck with it mate.
 
1 - 20 of 20 Posts
Top