Ducati 959 Panigale Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
163 Posts
Discussion Starter · #1 ·
Hey, friends. I keep my bike on a CTEK but admittedly, I haven’t ridden in probably 6-8 weeks. Traveling. But it’s been on the charger the whole time.

I went to ride today and turn the key, it made all the normal sounds. Hit the start button but only a load click or snap noise is made. It clicks/snaps for as long as I hold the start button. Engine doesn’t turn at all.

Now, it’s a 2016 so the battery is due for replacement I would guess, especially as ambient temperatures in a FL are quite warm but it’s always on a trickle charger.

I put the CTEK on “recondition mode” all day to give the battery some extra juice but still, no change. Dash indicates voltage of 12.1 V or so, which I believe is normal and sufficient yet the engine won’t even turn.

So… is the battery dead? Is a fuse blown? Or is something more serious awry?

I’m installing an Antigravity lithium tomorrow so I’ll see if that fixes it. Hopefully, this is just an excuse to buy an upgrade! :)

Thanks for your thoughts and help!
 

·
Registered
Joined
·
247 Posts
Mine did the same thing when the battery was low, it made all the right sounds but just a click out of the relay.
 

·
Registered
Joined
·
163 Posts
Discussion Starter · #3 ·
Great news. I have a new lithium battery, just waiting for free time to install it.
I was just confused how the battery could die when it’s been on a tender for years and when the voltage readout looks good.
Apparently, it can die on a tender and cranking amps have nothing to do with voltage. Swapping for a new battery should fix it all. I’ll follow-up with the results. Thanks!
 

·
Registered
Joined
·
109 Posts
I highly recommend EarthX batteries. I just replaced my 16 959 with it and it’s amazing! I have the recommended charger for them. To answer your question yes the stock lead acid batteries. Really suck and even if on a a good charger/ maintainer they have a limited life and low crank. The litio4 are amazing from earthx and made here in USA. I wish I knew about them sooner.
 

·
Registered
Joined
·
163 Posts
Discussion Starter · #5 ·
Installed the Antigravity lithium (which was a huge pain because the posts don’t line up and there’s very little play in the leads) and the bike started right up. Yay!
 
1 - 5 of 5 Posts
Top