Ducati 959 Panigale Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
So my 8 week old 959 has had 3 failures so far...
1) Cold Starting Issue (No Fix as yet)
2) Gear shift indicator failed and replaced under warranty.
3) Side stand sensor failed and replaced under warranty.

So just when I thought no further problems I was riding along tonight without issue when suddenly my check engine light came on then my ABS and whatever that triangle thing is started to flash( like before you start the bike with the ignition on). then the 3 boxes with ABS,TC and EB all went blank and I lost them all no ABS no Traction control and no quick shifter, this now reboots over and over in a loop. I can start the bike and it ride just fine.

Hoping someone has had this happen before and knows what the issue ended up being? but either way back to Ducati for the 4th time in 8 weeks :(
I have attached a picture to show everyone.

Thanks
 

Attachments

·
Registered
Joined
·
439 Posts
I am beginning to wonder if you have a battery or some other electrical issue. When running, what does it say the voltage output is?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
battery and voltage are fine. from what i can tell its the ECU its making a louder than normal humping sound. Also my hazard lights are going crazy flashing on and off so is the break light.
 

·
Registered
Joined
·
892 Posts
Maybe there's a squirrel eating your wiring harness.
 

·
Registered
Joined
·
70 Posts
Under almost every states lemon law, you can probably demand a replacement. Look into your state law... seems you likely got a lemon.
 

·
Premium Member
Joined
·
990 Posts
OK, let's settle down and have a little compassion for a fellow Ducati owner that's having problems. Just because we are not having the same issues as he is doesn't mean we shouldn't care. Just my .02
 

·
Registered
Joined
·
118 Posts
At what point should you lawyer up, and call it a lemon?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #12
Unfortunately in Australia there is No lemon law on Motorcycles only on automotive like cars etc.
I have been compensated extremely well by my dealer so happy to wait.
That problem is now fixed it was the connection under the fuel tank to the BBS controller...yes I dont really know the specifics or what that meant but its working well now.
My dealership also has two Test ECU's at the moment from Ducati to hopefully fix the Cold starting issue so fingers crossed.

3 issues fix
1 to go
0 more hopefully at least this year.
 

·
Registered
Joined
·
56 Posts
Unfortunately in Australia there is No lemon law on Motorcycles only on automotive like cars etc.
I have been compensated extremely well by my dealer so happy to wait.
That problem is now fixed it was the connection under the fuel tank to the BBS controller...yes I dont really know the specifics or what that meant but its working well now.
My dealership also has two Test ECU's at the moment from Ducati to hopefully fix the Cold starting issue so fingers crossed.

3 issues fix
1 to go
0 more hopefully at least this year.
Incorrect, motorcycles are most certainly covered under ACL (farm vehicles are not). I've just called my dealer and told them it's time to replace mine. As they've had it 5 weeks and are no closer to fixing the problem.
 

·
Registered
Joined
·
1,913 Posts
@MileyCyrus - it's be interesting to know exactly how many hours they've worked on the bike in those 5 weeks

I'm guessing 9 hours total

how about a Poll???
 

·
Registered
Joined
·
56 Posts
Sorry but you're actually incorrect I have already spoken to the ACCC to confirm it. Lemon laws don't apply to Motorcycles in Australia.

Lemon laws | Your rights, crime and the law | Queensland Government
https://www.accc.gov.au/publication...industry-guide-to-the-australian-consumer-law

They're correct Lemon Laws don't apply - because we don't have them in AUS

But we don't need them, we have ACL

ACL guidelines covers everything and anything purchased in AUS through as AUS retailer
 

·
Premium Member
Joined
·
990 Posts
Having the exact same issue. Mines now been in the shop for 4 weeks and they have no idea what's going on.



Very sorry to hear this, please keep us updated on what the dealer's find.
 
1 - 17 of 17 Posts
Top