Ducati 959 Panigale Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
So basically brand new bike. Less than 900ks when I first noticed this problem. During a pre ride check over I pulled in the clutch and heard a squeaking noise from around the slave cylinder. Only did it once and then was fine. Today I noticed it again except this time it squeaked consistently. Went for a short ride and when I got home it was worse. Now it was not only squeaking but also locking up and felt like a front brake. I removed the slave cylinder to inspect it and found that the black plastic spacer that fits inside the cylinder and over the end of the clutch push rod was seizing. There was hardly any lube on the spacers o ring so I’m thinking this is what was causing it to stick inside the cylinder. I lubed it with some rubber grease and put it all back together. It’s now silky smooth and quiet. Just some thing to keep an eye on.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #2 ·
Quick update. Went out for a decent long ride in the hills after fixing up the slave cylinder. Feels heaps better. So much smoother and no squeak or noise at all. Hopefully it stays that way long term. Anyone else had this issue.
 

·
Registered
Joined
·
892 Posts
I have not seen this myself, good thing you caught it proactively.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #4 ·
Yes it just started as an occasional sqeak then got worse. Since I’ve greased it it’s better than ever.
 
1 - 4 of 4 Posts
Top