Ducati 959 Panigale Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello guys, im new to this forum but i looked everywhere to find out if someone else has had this issue.

I few months ago I notice after riding on the track the my bike was squirting coolant on the ground, i asked some friends and they told me that it was normal because my bike was new and they probably over filled the reservoir at the dealer before giving me the bike. So i didnt think much of it.

It then happened on another trackday, and this time i got worried, so i took it to my dealer in QUITO, ECUADOR SOUTH AMERICA, so they could check the bike out. They told me that everything was fine and i had nothing to worry.

On ANOTHER trackday, it happened again, so i took it back to the dealer, and they did a more thorough inspection, and AGAIN told me that everything was fine, (no cracked hose, no loose cap, etc)

on my LAST trackday, everything went to ****. And I was cruising thru the straight at full throtle, my mates notice that my bike was sending a trail of white smoke, so I pitted and notice the TEMP gauge on HI.

Turned off the bike, loaded on the trailer and took it to the dealer.

They disassembled the colling system and found this (look at picture of the squirter unit)

They tell me the thermostat got burnt.

Has this happed to anybody else?????
 

Attachments

·
Registered
Joined
·
1,932 Posts
First time I saw something like that - hope they fix it for free and you didn't warp a head!
 

·
Registered
Joined
·
1 Posts
Hello guys, im new to this forum but i looked everywhere to find out if someone else has had this issue.

I few months ago I notice after riding on the track the my bike was squirting coolant on the ground, i asked some friends and they told me that it was normal because my bike was new and they probably over filled the reservoir at the dealer before giving me the bike. So i didnt think much of it.

It then happened on another trackday, and this time i got worried, so i took it to my dealer in QUITO, ECUADOR SOUTH AMERICA, so they could check the bike out. They told me that everything was fine and i had nothing to worry.

On ANOTHER trackday, it happened again, so i took it back to the dealer, and they did a more thorough inspection, and AGAIN told me that everything was fine, (no cracked hose, no loose cap, etc)

on my LAST trackday, everything went to ****. And I was cruising thru the straight at full throtle, my mates notice that my bike was sending a trail of white smoke, so I pitted and notice the TEMP gauge on HI.

Turned off the bike, loaded on the trailer and took it to the dealer.

They disassembled the colling system and found this (look at picture of the squirter unit)

They tell me the thermostat got burnt.

Has this happed to anybody else?????
Im
Not sure if you’re all sorted just now. I have a 2016 Panigale 959. Bought brand new and my squirter was perfect until I had a broken radiator and so the excess heat melted the squirter and the thermostat came out. I ordered the part from Italy as my local dealers don’t stock them. So it is rare and mine was unlucky. Yours was new and so no idea why. But it can happen. I had so much smoke. I could see it as I was riding
 
1 - 5 of 5 Posts
Top